• BLOG
  • Error Creating New Forms

    I just tried to create a new form in the GUI in Openspecimen v7.0.x.
    When I first saved the form without any control field, it worked:

    Testform was saved successfully.

    When I add a field it os says:

    Field1 added to the form successfully.

    Error saving the form.

    Now, when I go back to Forms and click on my Testform, there are no fileds in it.
    I created it as System Administrator.

    A workaround was, that I created a form in an older version <=5.3,
    exported it from their and imported it in the newer version.

    This worked quite well, exept that the checkbox ‘Show In Grid’ seems not to work correctly!
    I checked it, but the fields don’t show up in the GUI when I click ‘View Specimens’.

    I did this with

    Level:Specimen Custom Fields, Collection Protocol:ALL


    Level:Visit Forms, Collection Protocol:specific.

    The template csv-files have the additional fields,
    I can use them with ‘Scheduled-Bulk-Import’,
    but as said before the fields aren’t shown in the GUI!

    Is there anything that I can do in order to get it work correctly?

    Thanks for helping anyway.


    Christian Schorn